行きも帰りもMarkdownです。Notion、Apple Notes、Obsidian、あるいはどんなテキストファイルからでもリンクの一覧を取り出して、Trails®としてインポートできます。Horseがどんな形を作るのかは、トレイルのガイドで説明しています。逆に、トレイルをMarkdownとしてエクスポートして、ほかのどこにでも貼り付けることもできます。形式はただのテキストなので、囲い込まれる心配はありません。
リンクをインポートする
-
Horseでは、シンプルなテキスト形式であるMarkdownを使って、外部のアプリからリンクをインポートできます。
-
まず、元のアプリからリンクを書き出します。Apple Notesなら、テキストをコピーするだけです。ほかのアプリでは、そのアプリのエクスポート手順に従って、リンクをMarkdownで書き出してください。
-
たとえばNotionでは、•••メニューをクリックし、Exportを選んでMarkdown & CSVを選ぶと、リンクの一覧を書き出せます。NotionページのMarkdownファイルが、デスクトップに保存されます。

Image 11-09-2024 at 10.26.jpeg -
Horseを開いて、File > Import Trails(ファイル > トレイルをインポート)に進みます。Horseのインポートエディタが開きます。

Image 11-09-2024 at 11.40.jpeg -
インポート用のImportエディタで、メモアプリやMarkdownファイルのテキストを左の列に貼り付けます。右側にプレビューが表示されます。

Image 11-09-2024 at 13.05.jpeg -
必要に応じてテキストを編集します。
[Page](https://example.com)のようなMarkdownリンク、入れ子のページにはインデントしたリスト、フォルダには見出しを使います。構文の全体は、こちらのチートシートをどうぞ。
Image 11-09-2024 at 11.03.jpeg -
問題なければ、Importをクリックしてインポートします。
-
新しいトレイルが、サイドバーの一番上に現れます。そこで並べ替えたり、名前を変えたり、絵文字でカスタマイズしたりできます。

Image 11-09-2024 at 11.06.jpeg
Horseからリンクとトレイルをエクスポートする方法
-
Horseでは、トレイルをMarkdownテキストとしてエクスポートして、Markdownに対応したほかのアプリで使えます。
-
1つのトレイルをエクスポートするには、目的のトレイルを選択して、File > Copy Trail as Markdown(ファイル > トレイルをMarkdownとしてコピー)を選びます。現在のトレイルにあるすべてのリンクが、Markdownテキストとしてコピーされます。

Image 11-09-2024 at 10.15 (1).jpeg -
または、⌘を押しながらのクリックか、Shiftを押しながらのクリックで複数のトレイルを選択し、右クリックして選択したものをコピーします。
-
コピーしたテキストを好きなMarkdownエディタに貼り付けて、必要に応じて手を加えます。

Image 11-09-2024 at 10.19.jpeg -
最後に、そのアプリのインポート手順に従って、Markdownテキストを目的のアプリに貼り付けるか、インポートします。この例では、上のMarkdownテキストを新しいNotionページに貼り付けています。

Image 11-09-2024 at 12.08.jpeg
さらに詳しく
オフラインコピーのガイドでは、選んだトレイルを別の場所に保存する方法と、そのMarkdownコピーに何が含まれないのかを正確に説明しています。手で編集するなら、Markdownチートシートが構文のリファレンスになります。
